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[Abstract] Eukaryotic cells contain various types of cytoplasmic, non-membrane bound 

ribonucleoprotein (RNP) granules that consist of non-translating mRNAs and a versatile set of 

associated proteins. One prominent type of RNP granules are Processing bodies (P bodies), which 

majorly harbors translationally inactive mRNAs and an array of proteins mediating mRNA degradation, 

translational repression and cellular mRNA transport (Sheth and Parker, 2003). Another type of RNP 

granules, the stress granules (SGs), majorly contain mRNAs associated with translation initiation factors 

and are formed upon stress-induced translational stalling (Kedersha et al., 2000 and 1999). Multiple 

evidence obtained from studies in unicellular organisms supports a model in which P bodies and SGs 

physically interact during cellular stress to direct mRNAs for transport, decay, temporal storage or 

reentry into translation (Anderson and Kedersha, 2008; Decker and Parker, 2012). The quantification, 

distribution and colocalization of P bodies and/or SGs are essential tools to study the composition of 

RNP granules and their contribution to fundamental cellular processes, such as stress response and 

translational regulation. In this protocol we describe a method to quantify P bodies and SGs in somatic 

tissues of the nematode Caenorhabditis elegans. 
Keywords: Caenorhabditis elegans, mRNP granules, Processing bodies, Stress granules, 

Transgenesis 

 

[Background] Thus far, most protocols to study P bodies and SGs were developed for yeast or human 

cell lines (Buchan et al., 2010). Little is known about the function of somatic RNP granules in multicellular 

organisms. The simple model organism C. elegans has been extensively used to study germline-specific 

P granules, which are distinct from P bodies and SGs, and important structures for germline 

development and function (Updike and Strome, 2010). Although the principles of the presented 

procedure can be applied to count germline-specific P granules, the protocol focusses on the 

quantification of somatic RNP granules. Several studies have identified a conserved function of somatic 

P bodies in the translational deregulation via miRNA pathways in C. elegans (Ding et al., 2005; Zhang 

et al., 2007). More recently, various tools were created to study the involvement of cytoplasmic RNP 

granules in cellular and organismal stress response, development and ageing in the nematode (Cornes 
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et al., 2015; Huelgas-Morales et al., 2016; Rieckher et al., 2015; Rousakis et al., 2014; Sun et al., 2011; 

Table 1).  
  Such studies take advantage of the comparatively easy implementation of transgenesis methods in 

C. elegans that allow to constitutively express fluorescent fusion proteins (e.g., green fluorescent protein 

[GFP]), endogenously or in specific tissues (Rieckher et al., 2009). A collection of fosmids carrying gfp-

tagged P body- and SG-specific genes can be obtained at the ‘C. elegans TransGeneome’ project, a 

genome-scale transgenic project for fluorescent- and affinity-tagged proteins for expression in the 

nematode (Sarov et al., 2012; Table 1). C. elegans is transparent, which allows for efficient application 

of fluorescence microscopy methods that are easily combined with differential interference contrast (DIC) 

microscopy to reveal fluorescent protein expression in an anatomical context. Mounting transgenic 

animals for P body and SG imaging is based on a previously described method using nanoparticles for 

immobilization (Kim et al., 2013), since commonly applied anesthetics in C. elegans can induce stress, 

resulting in increased RNP granule formation. Fluorescence-tagged P body or SG-intensity can be 

imaged by epifluorescence light microscopy (see Procedure C), while fluorescence intensity, a detailed 

count and size measurements of P bodies and SGs can be obtained via confocal laser scanning 

microscopy (see Procedure D). 

 

Table 1. Tools available for transgenic expression of P body/SG-factors in C. elegans 

P body/SG factor 
yeast or human 

P body/SG factor 
C. elegans Fosmid$ Transgene 

published Reference 

P body-specific factors 

Dcp1 DCAP-1 Yes Yes* 
(Sun et al., 2011) 
(Rousakis et al., 2014) 
(Rieckher et al., 2009) 

Dcp2 DCAP-2 No Yes+ (Gallo et al., 2008) 
Edc-3 EDC-3 Yes No Tavernarakis lab, unpublished 
Dhh1 CGH-1 Yes Yes+ (Gallo et al., 2008) 

LSm1-7 

LSM-1 Yes Yes* (Cornes et al., 2015) 
LSM-3 No No Tavernarakis lab, unpublished 
LSM-4 Yes Yes* (Cornes et al., 2015) 
LSM-7 Yes No --- 

Xrn1 XRN-1 No No --- 
Ccr4/Pop2/Not1-5 CCR-4 Yes No --- 
GW182 AIN-1 Yes Yes (Ding et al., 2005) 
Argonaute ALG-1 No Yes (Ding et al., 2005) 
SG-specific factors 
Pat1p PATR-1 Yes Yes+ (Gallo et al., 2008) 

Cdc33/eIF4E& IFE-2 Yes Yes (Rousakis et al., 2014) 
(Rieckher et al., 2009) 

TIA1 TIAR-1 Yes Yes* 
(Sun et al., 2011) 
(Huelgas-Morales et al., 2016) 
(Gallo et al., 2008) 

*available at CGC 
+germline-specific promoter fusion 
$C. elegans TransGeneome project (Sarov et al., 2012) 
&can be found in both types of RNP granules 
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Materials and Reagents 
 

1. Sterile pipette tips  

2. Surgical disposable scalpel (Braun Medical, catalog number: 5518075) 

3. Worm Pick with platinum wire (Genesee Scientific, catalog numbers: 59-30P6) 

4. Pre-flattened tip (Genesee Scientific, catalog numbers: 59-AWP) 

5. Microscope slides (76 x 26 mm) (Carl Roth, catalog number: 0656.1) 

6. Cover slips (24 x 24 mm) (Carl Roth, catalog number: H875.2) 

7. Tape (~1 mm thickness) 

8. Greiner Petri dishes (60 x 15 mm) (Greiner Bio One, catalog number: 628161) 

9. C. elegans strains (see Table 1 for available transgenes) 

10. Escherichia coli OP50 strain (obtained from the Caenorhabditis Genetics Center) 

11. Nail polish 

12. Polysterine beads (Polybead, 2.5% by volume, 0.1 µm diameter) 

13. Potassium dihydrogen phosphate (KH2PO4) (Carl Roth, catalog number: P018.1) 

14. Di-potassium hydrogen phosphate (K2HPO4) (Carl Roth, catalog number: 5066.1) 

15. Sodium chloride (NaCl) (Sigma-Aldrich, catalog number: S9888) 

16. Di-sodium hydrogen phosphate (Na2HPO4) (Carl Roth, catalog number: T876.1) 

17. Bacto peptone (BD, catalog number: 211677) 

18. Streptomycin sulfate salt (Sigma-Aldrich, catalog number: S6501) 

19. Agar (Sigma-Aldrich, catalog number: 05040) 

20. Cholesterol stock solution (SERVA Electrophoresis, catalog number: 17101.01) 

21. Calcium chloride dehydrate (CaCl2.2H2O) (Sigma-Aldrich, catalog number: C5080) 

22. Magnesium sulfate (MgSO4) (Sigma-Aldrich, catalog number: M7506) 

23. Nystatin stock solution (Sigma-Aldrich, catalog number: N3503) 

24. Agarose (Biozym, catalog number: 840004) 

25. Phosphate buffer (1 M; sterile) (see Recipes) 

26. Nematode growth medium (NGM) agar plates (see Recipes)  

27. M9 buffer (see Recipes) 

28. 5% agarose pads (see Recipes) 

 

Equipment 
 

1. Dissecting stereomicroscope (Olympus, model: SMZ645) 

2. Epifluorescence microscope (ZEISS, model: Axio Imager Z2, objective EC Plan-Neofluar 

10x/0.3) 

3. Confocal microscope (we use the Zeiss LSM710 confocal microscope with an Argon multiline 

laser source 25 mW and a tunable laser with the wavelength range 488-640 nm) (ZEISS, model: 

LSM710) 
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4. Microwave 

5. Incubators for stable temperature (AQUA®LYTIC incubator 20 °C) 

6. Scale 

7. Cylindrical glass beaker (25 ml) (VWR, catalog number: 213-1120) 

8. Autoclave 

 

Software 
 

1. ZEN 2009 software (or later), Carl Zeiss AG, Jena, Germany (or any other software controlling 

a fluorescence microscope or confocal microscope) 

2. Microsoft Office 2011 Excel (Microsoft Corporation, Redmond, USA) 
3. Fiji or ImageJ (https://fiji.sc/ or https://imagej.nih.gov/ij/) 

 

Procedure 
 
A. Growth and synchronization of transgenic C. elegans population 

1. When working with a transgenic strain with integrated genetic array (Table 1), use a sterile 

pipette tip (200 µl) to cut a small chunk (0.5 x 0.5 cm) of agar containing animals from an older 

plate and transfer it to a freshly Escherichia coli (OP50) seeded NGM plate (see Recipes). When 

working with a transgenic line with a non-integrated extrachromosomal array, pick ~25 L4 larvae 

or adult transgenic animals based on the selection-marker to a freshly OP50 seeded NGM plate. 

2. Incubate the nematodes at the standard temperature of 20 °C.  

3. 3.5 days later the plates contain a mixed population of larval stages. 

4. Synchronize nematodes by picking ~30 transgenic animals in L4 stage under a dissecting 

stereomicroscope and transfer them onto separate OP50 seeded plates. The L4 stage can be 

identified based on the presence of a half-moon shaped light structure in the area of the vulva 

and the relative size of the animal (Figure 1). 

5. Grow the animals for 24 h at 20 °C into day 1 adults and proceed with mounting the sample 

(Procedure B). 
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Figure 1. Identification of C. elegans larval stages in a mixed population. The image 

depicts all 4 larval stages, young adult and day 1 adult as seen under a dissecting 

stereomicroscope. The arrow indicates the half-moon shaped structure in the area of the vulva, 

which is indicative for the L4 larval stage. 

 

B. Mounting animals for imaging 

1. Prepare fresh 5% agarose pads (see Recipes). 

2. Pipette 3 µl polystyrene beads suspension in the center of the agarose pad. 

3. Use a platinum wire to pick ~30 transgenics from the OP50 seeded plates into the polystyrene 

bead suspension. 

4. Gently place a coverslip on top of the agarose/worm suspension and proceed with the imaging 

procedure. Optionally, the agarose pads can be sealed with nail polish, which will retain humidity 

for long-term (> 3 h) imaging. 

5. Animals can be recovered from unsealed plates by gently lifting one edge of the coverslip with 

the help of a scalpel and adding 10 µl of M9 buffer to suspend the worms. Subsequently, worms 

can be transferred with an eyelash to OP50-seeded NGM plates. 

 

C. Imaging P body/SG number with an epifluorescence light microscope 

1. Start up the light microscope and imaging software (ZEN, Zeiss). 

2. Place the agarose pad on the imaging stage of the fluorescent light microscope and locate the 

animals. Use a 10x objective to image the whole animal. 

3. Use the DIC channel to focus on an anatomical landmark. Most appropriate are the grinder and 

the lumen of the pharynx, which are located in the most central transverse (horizontal) position 

within the animal (Figure 2A). 

4. Change to the fluorescent channel to visualize P body or SG-specific fluorescence and define 

exposure time and fluorescent light intensity. These parameters depend on the transgene and 

have to be defined empirically. Saturation of the fluorescent signal has to be avoided by lowering 

exposure time and/or fluorescent light intensity. However, too short exposure might result in 
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lowered sensitivity of detecting RNP granules (Figure 2B). For transgenes that co-express 

various reporters for P bodies/SGs repeat this step in the corresponding fluorescent channel. 

5. Once the best imaging conditions are determined take a snapshot of all fluorescent channels 

and the DIC channel. Take images of at least 25 animals to obtain enough data for statistical 

analysis. 

6. Save the data as an image stack. Zeiss microscopes produce *.czi file formats, which can be 

processed by ImageJ/Fiji freeware (see Data analysis). However, images can also be 

stored/exported and further processed in any other common format including *.jpg, *.png, *.tiff, 

etc., and then proceed with the data analysis. 

 

 
Figure 2. Representative images of epifluorescence images of an adult transgenic animal 
expressing the P body reporter DCAP-1::dsRED. Images were recorded with an Axio Imager 

Z2 through a 10x magnification objective. Size bars are 100 µm. A. DIC image. The inlay shows 

a digitally enhanced view on the pharynx. The arrow points out the grinder, which has to be in 

focus before switching to the fluorescent channel. B. Fluorescent image of the P body reporter 

DCAP-1::dsRED. C. Screenshot of image processing. Choose the polygon selection tool to 

surround the whole animal. Open Analyze > Measure to get area size and MPI. (Full genotype 
of transgenic animal: N2;Ex[pdcap-1DCAP-1::dsRED; pRF4] published in Rieckher et al., 2015.) 

 

D. Imaging P body/SG number, dynamics and colocalization with a confocal microscope 

1. Start up the confocal microscope and corresponding imaging software. 

2. Activate the appropriate laser(s) for fluorescent detection of P body/SG reporters. 

3. Locate the animal through the eyepiece with a 10x objective using transmission light and center 

the field of view on the area of interest (e.g., the pharynx). 

4. Upon localization, switch to the 40x objective and readjust the focus. 

5. In the confocal operating software (acquisition) design a protocol for a z-stack scan. 

a. Different RNP granules significantly vary in size and intensity across different transgenes 

and within samples (Teixeira et al., 2005). Hence, a balance has to be established 

empirically between laser power and gain (voltage of photomultiplier tubes [PMTs]/detectors) 

to set the highest and lowest detection limit. If available, use the Smart Setup as a starting 

point. Try to avoid overexposure but test the lower detection limit by stepwise increasing 

laser power and/or gain. The final settings have to be reproducibly applied to all samples. 

http://www.bio-protocol.org/e2108
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For the example in Figure 2 we use the tunable laser at 570 nm (excitation dsRED), laser 

power 3%, and Master gain 580. 

b. Keep the pinhole size for an optimal section thickness at 1 AU.  

c. The distance between z-stacks (slices) should be maximum 1.5 µm. Decreasing z-stack 

distance might enhance the capability to detect smaller RNP granules but increases 

photobleaching. Cover a similar volume in each scanned sample. We perform 30 z-stacks 

at 1.5 µm across the pharyngeal region (Figures 2 and 3). 

d. Assign the frame size (resolution). We use 1024 x 1024 (Figures 2 and 3). 

e. Use the transmitted light detector (T-PMT) to produce a DIC/Brightfield image in parallel 

(optional). 

6. Once the best imaging conditions are determined perform a scan of the fluorescent channel. 

When imaging different P bodies/SGs co-expressed in the same transgene use sequential scan 

for additional fluorescent channels. Take datasets of at least 15 animals to obtain enough data 

for statistical analysis. 

7. Upon completion of the scan use the processing mode of the ZEN software to produce a 

maximum intensity projection (MIP), summarizing the fluorescence intensity of all stacks in one 

image (Figures 3A and 3B). Consistently save as *.czi file or other image file format. Proceed 

with data analysis. Alternatively, single stacks or subsets of stacks can be processed and 

analyzed. 

 

 
Figure 3 Representative images of the pharyngeal region of an adult transgenic animal 
expressing the P body reporter DCAP-1::dsRED and the SG reporter IFE-2::GFP. Images 

were recorded with an LSM710 confocal microscope and processed into MIP. Size bars are 50 

µm. A. P body reporter DCAP-1::dsRED expression. B. SG reporter IFE-2::GFP. C. Screenshot 

of image processing via Fiji/ImageJ. Use the polygonal tool to surround the area of interest, 

assign a threshold and use Analyze Particles to obtain information about P body/SG intensity, 

number and size. (Full genotype of transgenic animal:N2;Ex[pdcap-1DCAP-1::dsRED; pife-2IFE-

2::GFP; pRF4] published in Rieckher et al., 2015.) 
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Data analysis 
 

1. Processing P body- and SG-data with Fiji (ImageJ) 

a. Download and install the Fiji freeware from https://fiji.sc/. 

b. Open an image file from fluorescence microscopy or a MIP file from confocal laser scanning 

microscopy by dragging/dropping into the Fiji software. 

c. Images will open as stacks of DIC and the fluorescent channels that were recorded. In the 

control panel of Fiji chose Image > Stacks > Stack to images to split the channels. 

d. Change Image > Type > 8 bit for further analysis steps. 

e. Chose the image of the fluorescent channel that should be analyzed and apply the polygon 

selection tool to further narrow down the region of interest (ROI). For images received from 

fluorescence microscopy encircle the whole animal (Figure 2C). In MIP images a specific 

region, such as the pharynx, should be selected (Figure 3C). 

f. For epifluorescence images choose ‘Analyze > Measure’ to obtain a summary about the 

Area size and the mean pixel intensity (MPI) in arbitrary units (AU) of the assigned area. 

This information will be displayed in a separate window and can be copied/pasted directly 

from there in a data analysis software and/or saved as an excel file (*.xls). 

g. For confocal images proceed with the measurement of P body and SG number and size a 

threshold has to be determined that assigns single pixels or pixel clusters to define 

fluorescent RNP granules. Chose Image > Adjust > Threshold and empirically assign a 

proper Min/Max value (Figure 3C). This value will vary depending on the transgene, choice 

of microscope and the imaging settings. Once assigned, these values have to stay 

consistent throughout every analysis. 

h. Chose Analyze > Analyze Particles and tick ‘Display results’, ‘Summarize’ and ‘Exclude on 

Edges’ and press OK (Figure 3C). 

i. Two separate Windows display the ‘Results’ for every RNP granule, producing Area 

(Granule size) and Mean (MPI), and the ‘Summary’ including ‘Count’ (RNP granule number), 

‘Total Area’ and ‘Average Size’. These data can be copied directly into a data analysis 

software and/or saved as excel file. 

2. Statistical analysis 

a. Stay consistent with the number of animals examined for each strain and condition. 

b. Each assay should be repeated at least three (3) times.  

c. Use the Mann Whitney or Wilcoxon Kruskal Wallis test with a significance cut-off level of P 

< 0.05 for comparisons between different groups and correct for multiple pairwise 

comparisons using Bonferroni or False Discovery Rate (FDR). 

 
 
 
 

http://www.bio-protocol.org/e2108
https://fiji.sc/


                 www.bio-protocol.org/e2108    
Vol 7, Iss 02, Jan 20, 2017 
DOI:10.21769/BioProtoc.2108

 
 

9 

Notes 
 

P bodies and SGs are known to substantially vary in size and number across cells (Teixeira et al., 

2005). Measurements become more precise and final values underlie less standard deviation when 

focusing on quantification in specific tissues (e.g., muscles, pharynx, or intestine) and increasing 

sample size.  

 

Recipes 
 

1. Phosphate buffer (1 M) 

a. For 1 L, dissolve 102.2 g KH2PO4 and 57.06 g K2HPO4 in distilled water and fill up to 1 L. 

This is a 1 M solution, pH 6.0 

b. Autoclave at 121 °C for 20 min 

c. Store at room temperature 

2. Nematode growth medium (NGM) agar plates 

a. Mix 3 g NaCl, 2.5 g Bacto peptone, 0.2 g streptomycin, 17 g agar and add 900 ml distilled 

water. Autoclave at 121 °C for 20 min 

b. Let cool to 55-60 °C 

c. Add 1 ml cholesterol stock solution, 1 ml 1 M CaCl2, 1 ml 1 M MgSO4, 1 ml nystatin stock 

solution, 25 ml sterile 1 M phosphate buffer, pH 6.0, and distilled sterile water up to 1 L 

d. Pipette 8 ml medium per Petri dish and leave to solidify 

e. Store the plates at 4 °C until use 

3. M9 buffer 

a. Dissolve 3 g KH2PO4, 6 g Na2HPO4, 5 g NaCl in 1 L distilled water 

b. Autoclave at 121 °C for 20 min 

c. Let cool and add 1 ml 1 M MgSO4 (sterile) 

d. Store M9 buffer at 4 °C 

4. 5% agarose pads 

a. Weigh 0.5 g agarose and add it into a cylindrical glass beaker 

b. Add 10 ml M9 buffer 

c. Heat the mixture in a microwave until it is close to boiling. Take it out, stir with a pipette tip 

and boil again. Repeat until the agarose is dissolved completely 

d. Modify two microscope slides by putting a stripe of tape along the midline 

e. Place an empty microscope slide between two taped slides (Figure 4A) 

f. Put a drop (ca. 50 µl) of fresh 5% agarose solution in the middle of the slide (Figure 4B) 

g. Take a fourth microscope slide and place it on top of the agarose drop. Gently press down 

to flatten the drop. The tape serves as spacer to give the agarose pad a specific thickness 

(Figure 4C) 

h. Let the agarose harden for 30 sec and remove the top microscope slide 

http://www.bio-protocol.org/e2108
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i. Quickly cut the edges of the agarose pad with the scalpel to a square of approximately 20 

x 20 mm 

j. Immediately proceed with the sample preparation (see Procedure B), since the agarose 

pads will start drying within approximately 5 min 

Note: Leaving the top microscope slide as a cover contains the humidity longer (approx. 1 

h). Thus, several agarose pads can be prepared and used swiftly during the experiments. 

 

 
Figure 4. Preparation of agarose pads for fluorescent imaging in C. elegans. A. Two glass 

slides modified with tape flank an empty microscope slide. B. Place a drop of 50 µl 5% agarose 

solution in the middle of the microscope slide (arrow). C. Swiftly put another microscope slide 

on top and gently push it down to flatten the agarose drop. 
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